iOS 4.3.4 released, patches JailbreakMe exploit

Jul 15, 2011 by

 

iOS 4.3.4

Literally just moments ago, Apple has pushed out a new firmware update for its iOS devices — iOS 4.3.4, which was designed solely to fix the JailbreakMe.com PDF exploit.

Though this is a somewhat important security risk to deal with, the following devices are left in the dust (again) when it comes to the patch: iPod touch 1st generation, iPod touch 2nd generation, iPhone 2G and the iPhone 3G. If you use one of those aforementioned devices, it is recommended you jailbreak and install PDF Patch 2 (and PDF Patch if you’re device is under iOS 4.0.2).

We recommend that you do not update, as it would render your device unjailbroken and unjailbreakable if you do not have the appropriate SHSH blobs saved.